SMS сообщения со спецсимволами

-

Общий форум по Symbian



q1pinfium


репутация: 33
на сайте с 2008 года
сообщений: 246

Брянск

Возраст - 30

#1

У моего начальника Nokia семейство S40. Он управляет GSM модулем своей машины при помощи команд например *x1**110#. Сегодня утром у него телефон перестал отправлять на GSM модуль сообщение, а именно он обрезает первый символ... Если отправить **x1**110# то сообщение доходит без 1 первой звездочки, т.е имеет вид *x1**110#. Оператор у него МТС. Кто может что подсказать? раньше такого не было. Интересно то что если он мне такую команду присылает на мой телефон Nokia 808, то телефон почему то тупить начинает крутится колесико загрузки и сообщение открывается его можно прочитать, но интересно то что оно открывается не в разговоре а как в режиме Просмотр по папкам. Если нажать кнопку НАЗАД то сообщение пропадает его нет в списке... Кто нибудь с таким сталкивался???


тема создана:

Рейтинг: 4
голосов: 1

Zag.Oleg


репутация: 1896
на сайте с 2006 года
сообщений: 1361

Мариуполь

Возраст - 44

#2

Как вы понимаете, что обрезает? В отправленных? И что за сигнализация, модель?

q1pinfium


репутация: 33
на сайте с 2008 года
сообщений: 246

Брянск

Возраст - 30

#3

Ну он мне отправляет сообщение с 1 звездочкой и с 2 звездочками. Обрезается первый символ звездочки

gr429842534


репутация: 957
на сайте с 2013 года
сообщений: 3702

Nokia E72

#4

q1pinfium,
а если отправлять с тремя звёздочками или пробелом (ставить лишний знак т.е.).

q1pinfium


репутация: 33
на сайте с 2008 года
сообщений: 246

Брянск

Возраст - 30

#5

Тогда придет 2 звездочки вместо 3

gr429842534


репутация: 957
на сайте с 2013 года
сообщений: 3702

Nokia E72

#6

Цитата: q1pinfium
 Тогда придет 2 звездочки вместо 3


я это и имел в виду: если обрезается первый (нужный) знак, вставлять лишний.
Придёт что надо.
Видимо, не срабатывает?


Напомнить пароль